re = /"[^"]+":\s*"[^"]+"[,}]\s*(*SKIP)(*FAIL)|(?<![,:])"(?![:,]\s*["}])/
str = 'json_str = \'\'\'{"id":"9","ctime":"2018-02-13","content":"abcd: "efg.","hots":"103b","date_sms":"2017-11-22"}\'\'\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end