#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(0?[1-9]|1[0 12]):([0-5]\d)\s?((?:A|P)\.?M\.?)"
Local $sString = "12:40 pm" & @CRLF & _
"1:25 A.M." & @CRLF & _
"05:44p.m" & @CRLF & _
"19:55AM." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")