using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(0?[1-9]|1[0 12]):([0-5]\d)\s?((?:A|P)\.?M\.?)";
string input = @"12:40 pm
1:25 A.M.
05:44p.m
19:55AM.
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}