use strict;
my $str = '12:40 pm
1:25 A.M.
05:44p.m
19:55AM.
';
my $regex = qr/(0?[1-9]|1[0 12]):([0-5]\d)\s?((?:A|P)\.?M\.?)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}