$re = '/\.0*([^0])|^([^0])/m';
$str = '0.18
0.004
0.01920
0.000000000000086351
0.90000000
815805
1
2
50
5000
180843
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);