$re = '@^model/[^/]+/model_more/(\d+)/?$@';
$str = 'model/benz/model_more/5/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);