re = /(?<![a-zA-Z])[0-9][\.0-9]*(?![a-zA-Z])/
str = 'Theses are some of the fail cases that I am looking to
avoid variable123 or variable_123name or _123_,
where some of the acceptable cases are |123| or +123+ $123 123% #124523 ext... 11 2123 123% 0.12 1.1.3.4.4 12 1 23452 23423| ext...['
# Print the match result
str.scan(re) do |match|
puts match.to_s
end