# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=[A-Za-z ]{3,15}$)(?=[A-Za-z ]*[A-Za-z]{3})(?:\b[A-Z]?[a-z]*\ ?\b){1,3}$"
test_str = ("Yaw\n"
"yaw\n"
"James Bond\n"
"Monkey D Luffy\n"
"List item\n"
"Mas few def\n"
"Mas no no\n"
"No mas no\n"
"No no mas\n"
"Masa no no\n"
"aa Mdef\n"
"Jamesbondokskdk\n"
"YaW\n"
"Two spaces\n"
"No no no\n"
"abg def ghi \n"
"JamesBond")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.