# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[A-Z\d](?:(?!\d+\.\d)[A-Z\d.\h])*[A-Z]{3,}"
test_str = ("ID.4 ESTATE 109kW City Pure 52kWh 5dr Auto\n"
"XC40 DIESEL ESTATE 2.0 D4 [190] Inscription Pro 5dr AWD Gea+\n"
"RAPID DIESEL HATCHBACK 1.6 TDI CR Elegance 5dr\n"
"MODEL 3 120kW LONG RANGE AWD \n"
"V40 DIESEL HATCHBACK D2 [120] Momentum 5dr Geartronic\n"
"V60 DIESEL SPORTSWAGON 2.0 D4 [190] R DESIGN Plus 5dr Auto\n"
"X3 ESTATE xDrive M40i 5dr Auto\n"
"C CLASS DIESEL SALOON C250 BlueTEC SE 4dr Auto\n"
"A CLASS DIESEL HATCHBACK A180d Sport Executive 5dr Auto\n"
"2 SERIES COUPE 218i Sport 2dr [Nav] Step Auto\n"
"HILUX SPECIAL EDITIONS Invincible X Ltd Ed D/Cab P/Up 2.4 D+\n"
"C3 PICASSO 1.6 BlueHDi Platinum 5dr\n"
"C3 HATCHBACK 1.2 PureTech 82 Flair 5dr\n"
"XC40 DIESEL ESTATE XC40\n"
"1")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.