package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^linux-.*-5\.0\.0-38(-generic)?$`)
var str = `linux-image-unsigned-5.0.0-38-generic
linux-image-5.0.0-38-generic
linux-headers-5.0.0-38-generic
linux-modules-extra-5.0.0-38-generic
linux-modules-5.0.0-38-generic
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}