$re = '/^linux-.*-5\.0\.0-38(-generic)?$/m';
$str = 'linux-image-unsigned-5.0.0-38-generic
linux-image-5.0.0-38-generic
linux-headers-5.0.0-38-generic
linux-modules-extra-5.0.0-38-generic
linux-modules-5.0.0-38-generic
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);