$re = '/.(?R)?<BckSp>/';
$str = 'Helllo<BckSp><BckSp>o world';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;