$re = '/^[0-9]{4}[-\/][0-9]{3}$/mi';
$str = '123456/0000-000
0000-000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);