Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(0[1-9]|[12][0-9]|3[01])(\/|-)?(0[1-9]|1[012])(((\/)?([0-9]{4}|[0-9]{2}))|((\/|-)?[0-9]{4}))$
/
gm
Input 1
1
New
13/10/2022 10/10/2022 13/10/22 10/10/22 13-10-2022 10-10-2022 13-10-22 10-10-22 131022 101022 13102022 10102022 20221013 20221010 2022-10-13 2022-10-10 2022/10/13 2022/10/10