using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"0[1-9][0-9]{5}";
string input = @"0258714 0465666 1213655 568464668 225 75487 021523
56556 0236589 ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}