$re = '/0[1-9][0-9]{5}/';
$str = '0258714 0465666 1213655 568464668 225 75487 021523
56556 0236589 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);