#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<sale_items>\$.+(?<=\.99)$)"
Local $sString = "$14.99" & @CRLF & _
"$156.98" & @CRLF & _
"$85.99" & @CRLF & _
"$43.97" & @CRLF & _
"$1.98" & @CRLF & _
"$83.74" & @CRLF & _
"$1,601.99" & @CRLF & _
"" & @CRLF & _
"1" & @CRLF & _
"12" & @CRLF & _
"123" & @CRLF & _
"123,456" & @CRLF & _
"123,456,789" & @CRLF & _
"123,456,789.01"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")