const regex = /(?P<sale_items>\$.+(?<=\.99)$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<sale_items>\\$.+(?<=\\.99)$)', 'gm')
const str = `\$14.99
\$156.98
\$85.99
\$43.97
\$1.98
\$83.74
\$1,601.99
1
12
123
123,456
123,456,789
123,456,789.01`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}