use strict;
my $str = '$14.99
$156.98
$85.99
$43.97
$1.98
$83.74
$1,601.99
1
12
123
123,456
123,456,789
123,456,789.01';
my $regex = qr/(?P<sale_items>\$.+(?<=\.99)$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}