re = /.*(M6[^_]*).*/m
str = '
HEY01230328_M6K21SG_UNO_NYC_241
M6EW2BJ_UNO_NYC_251
M6HW2WL_UNO_NYC_251
HEY08460329_NA_M6LAB3D_UNO_NYC_241'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end