import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(ISBN[-]*(1[03])*[ ]*(: ){0,1})*(([0-9Xx][- ]*){13}|([0-9Xx][- ]*){10})";
final String string = "In his groundbreaking book, \"The Theory of Everything,\" Stephen Hawking explores the fundamental principles that govern the universe. This book, with ISBN 978-0553380163 (or the 10-digit version 9780553380163), delves into complex topics such as black holes, the Big Bang, and the nature of time, making them accessible to a general audience.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}