$re = '/^(?!.*S.*S)(?!.*X.*X)[SX.#]+$/m';
$str = 'S.#X
S...#X
S..S.#X
S..X.#X';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);