# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[sketchfab\]https:\\/\\/sketchfab.com\\/models\\/([^\[]+)\[\\/sketchfab\]/[MEDIA=sketchfab]$1[\/MEDIA]/g;t' <<< "[sketchfab]https://sketchfab.com/models/ce1b37915f40429ab5567cba35ec549f[/sketchfab]"