using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[sketchfab\]https:\/\/sketchfab.com\/models\/([^\[]+)\[\/sketchfab\]";
string substitution = @"[MEDIA=sketchfab]$1[/MEDIA]";
string input = @"[sketchfab]https://sketchfab.com/models/ce1b37915f40429ab5567cba35ec549f[/sketchfab]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}