use strict;
my $str = '[sketchfab]https://sketchfab.com/models/ce1b37915f40429ab5567cba35ec549f[/sketchfab]';
my $regex = qr/\[sketchfab\]https:\/\/sketchfab.com\/models\/([^\[]+)\[\/sketchfab\]/p;
my $subst = '[MEDIA=sketchfab]$1[/MEDIA]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";