$re = '/\[sketchfab\]https:\/\/sketchfab.com\/models\/([^\[]+)\[\/sketchfab\]/';
$str = '[sketchfab]https://sketchfab.com/models/ce1b37915f40429ab5567cba35ec549f[/sketchfab]';
$subst = "[MEDIA=sketchfab]$1[/MEDIA]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;