$re = '/"(?:km|rua)+\s*\D+?"/m';
$str = 'rua 5", "rua x, casa y", "km 18", "km x"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);