re = /(?:ds_user_id=)(.+?)(?:;)/m
str = 'fxs_124024574287414=base_domain=.example.com; datr=KWHazxXEIkldzBaVq_of--syv5; csrftoken=szcwad; ds_user_id=219132; mid=XN4bpAAEAAHOyBRR4V17xfbaosyN; sessionid=14811313756%12fasda%3A27; rur=VLL;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end