$re = '/\.(\d+)/m';
$str = 'iso.3.6.1.4.1.2011.6.128.1.1.2.21.1.6.4194455040';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);