import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*(input|output|inout)\\s+(wire\\s*|reg\\s*)?\\s*(\\[(\\d+):(\\d+)\\])?\\s*(\\w+)?";
final String string = "x\n"
+ "input z\n"
+ "input [1:0] az\n"
+ "input wire [1:0] za\n"
+ "input wire [1:0]\n"
+ "y\n"
+ "z\n"
+ "output [12:0] a\n\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}