const regex = new RegExp('\\s*(input|output|inout)\\s+(wire\\s*|reg\\s*)?\\s*(\\[(\\d+):(\\d+)\\])?\\s*(\\w+)?', 'g')
const str = `x
input z
input [1:0] az
input wire [1:0] za
input wire [1:0]
y
z
output [12:0] a
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}