import re
regex = re.compile(r"\s*(input|output|inout)\s+(wire\s*|reg\s*)?\s*(\[(\d+):(\d+)\])?\s*(\w+)?")
test_str = ("x\n"
"input z\n"
"input [1:0] az\n"
"input wire [1:0] za\n"
"input wire [1:0]\n"
"y\n"
"z\n"
"output [12:0] a\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")