#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-?(?=\d{1,15}(?:[.,]0+)?0*$|(?:(?=.{1,16}0*$)(?:\d+[.,]\d+))).+$"
Local $sString = "// PASS" & @CRLF & _
"0" & @CRLF & _
"0.00" & @CRLF & _
"1" & @CRLF & _
"-1" & @CRLF & _
"1.23456789012345" & @CRLF & _
"10.2345678901234" & @CRLF & _
"12.3456789012345" & @CRLF & _
"-123.4" & @CRLF & _
"-12.34" & @CRLF & _
"-1,33" & @CRLF & _
"-1.33" & @CRLF & _
"-123456789012345" & @CRLF & _
"-1234567890123450" & @CRLF & _
"-12345678901234.50" & @CRLF & _
"12345678901234.50" & @CRLF & _
"123456789012345.00" & @CRLF & _
"" & @CRLF & _
"// FAIL" & @CRLF & _
"-1234567890123456" & @CRLF & _
"-12345678901234.56" & @CRLF & _
"12345678901234.56" & @CRLF & _
"123456789012345.60" & @CRLF & _
"1.234567890123456" & @CRLF & _
"12.34567890123456" & @CRLF & _
"123456789012340.6" & @CRLF & _
"123456789012300.67" & @CRLF & _
"123456789012300000000000.67" & @CRLF & _
"10000000000010000000001000010000000001.22"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")