$re = '/<mj-image([^>/]*)>([^]*?)<\/mj-image>/mi';
$str = '<mj-image-variable variable="user.image_url"></mj-image-variable>
<mj-image></mj-image>
<mj-image src="https://example.com/image.png"></mj-image>
<mj-image
src="https://example.com/image.png"
></mj-image>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);