$re = '/(.*)#([0-9]+) - ([\w]+) change ([0-9]+) [(]binary[+]Fl[)]/m';
$str = '//depot/Flow/05_clean/Defense_Onball/Move_9076_001.fbx#1 - add change 1466 (binary+Fl)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);