re = /(.*)#([0-9]+) - ([\w]+) change ([0-9]+) [(]binary[+]Fl[)]/m
str = '//depot/Flow/05_clean/Defense_Onball/Move_9076_001.fbx#1 - add change 1466 (binary+Fl)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end