#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(?:(?:"?((\w+)\b.*\b)"?)\s)?<?(([\w@]*)@(\w*)\.[a-zA-Z]{2,3})>?,?"
Local $sString = "peter@pan.com, " & @CRLF & _
"lucky <jack@pot.com>, " & @CRLF & _
""William Tell" <billy@tell.com>, " & @CRLF & _
""John Rambo, III" <johnny@rambo.com>, " & @CRLF & _
""there, might, be, several, commas inside the quotes" <multiple@commas.com>, " & @CRLF & _
""yes, this is also a valid email address, can you believe" <yes@this@is@valid.com>"
Local $sSubst = "{ fullName:'\1', firstWord:'\2', localPart:'\4', company:'\5', email:'\3'}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)