using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.{51,}).{1,}?@.{4,}?$";
string input = @"@1234
1@123
1@1234
1234567890@123456789012345678901234567890123456789
1234567890@1234567890123456789012345678901234567890";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}