re = /^(?!.{51,}).{1,}?@.{4,}?$/m
str = '@1234
1@123
1@1234
1234567890@123456789012345678901234567890123456789
1234567890@1234567890123456789012345678901234567890'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end