import re
regex = re.compile(r"^([\w-\.+]+)@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.)|(([\w-]+\.)+))([a-zA-Z]{2,4}|[0-9]{1,3})(\]?)$", flags=re.MULTILINE)
test_str = ("Invalid:\n"
"mkyong\n"
"mkyong123@.com\n"
"mkyong()*@gmail.com\n"
"mkyong@%*.com\n"
"mkyong..2002@gmail.com\n"
"mkyong.@gmail.com\n"
"mkyong@mkyong@gmail.com\n"
"mkyong@gmail.com.1a\n\n"
"Valid:\n"
"mkyong@yahoo.com\n"
"mkyong-100@yahoo.com\n"
"mkyong.100@yahoo.com\n"
"mkyong111@mkyong.com\n"
"mkyong-100@mkyong.net\n"
"mkyong.100@mkyong.com.au\n"
"mkyong@1.com\n"
"mkyong@gmail.com.com\n"
"mkyong-100@yahoo-test.com\n"
"a.a@ac.cc.cc\n"
"mkyong@fdg\n"
".dgfsdfg@dgf.dfg\n"
"mkyong+123@df.com\n"
"firstname+lastname@domain.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")