use strict;
my $str = '<a href="/#abc">test</a>
<a href="#def">test2</a>
<a href="/index.php?a=1#feg">test3</a>
<a href="/test.php?c=2">test4</a>
<a href="/test">test5</a>
';
my $regex = qr/href="([^#]*?)(#[^"]*?)"/mp;
my $subst = 'href="$1"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";