use strict;
my $str = 'names.with.periods.and.extension
names#with$Special&chars*yuhyuh.yuh.yuh..yuhyuh
Normal . Name . with 123 some numbers.mp3
Normal . Name . with 123 some numbers.mpeg
Normal . Name . with 123 ..some . numbers mpeg.123';
my $regex = qr/\.(?![a-z0-9]{3,4}$)/mp;
my $subst = '@@@';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";