import Foundation
let pattern = #"\.(?![a-z0-9]{3,4}$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
names.with.periods.and.extension
names#with$Special&chars*yuhyuh.yuh.yuh..yuhyuh
Normal . Name . with 123 some numbers.mp3
Normal . Name . with 123 some numbers.mpeg
Normal . Name . with 123 ..some . numbers mpeg.123
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"@@@"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)