using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?is)(?<=([a-z])\s)(\1)([a-z]*)";
string input = @"word dark king glow we end hello bye low wing
word Dark King Glow We End hello bye LoW wing
A a A b B C c C C";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}