import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$\\{\\s*(?<path>[a-zA-Z_$]\\w*(?:\\.[a-zA-Z_$]\\w*)*)\\s*\\}";
final String string = "Hello, ${ name } Hello, ${ 0name } Hello, { name }\n"
+ "Hello, ${ _name_01 } Hello, ${ name$ } Hello, ${ _name_01 }\n"
+ "Hello, ${ $_name_2 }\n"
+ "Hello, ${ user.name.first } ${ user.name.last }!\n"
+ "Hello, ${ type.user.name.first.f1 } { type.user.name.last }!\n"
+ "Hello, ${ type.0user.name.first.f1 } ${ type.$user.name.last }!\n"
+ "Hello, ${ type.$user0._name_.first.f1 } ${ type.user$.name.last }!\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}