const regex = /\$\{\s*(?<path>[a-zA-Z_$]\w*(?:\.[a-zA-Z_$]\w*)*)\s*\}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$\\{\\s*(?<path>[a-zA-Z_$]\\w*(?:\\.[a-zA-Z_$]\\w*)*)\\s*\\}', 'g')
const str = `Hello, \${ name } Hello, \${ 0name } Hello, { name }
Hello, \${ _name_01 } Hello, \${ name\$ } Hello, \${ _name_01 }
Hello, \${ \$_name_2 }
Hello, \${ user.name.first } \${ user.name.last }!
Hello, \${ type.user.name.first.f1 } { type.user.name.last }!
Hello, \${ type.0user.name.first.f1 } \${ type.\$user.name.last }!
Hello, \${ type.\$user0._name_.first.f1 } \${ type.user\$.name.last }!
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}