use strict;
my $str = 'Hello, ${ name } Hello, ${ 0name } Hello, { name }
Hello, ${ _name_01 } Hello, ${ name$ } Hello, ${ _name_01 }
Hello, ${ $_name_2 }
Hello, ${ user.name.first } ${ user.name.last }!
Hello, ${ type.user.name.first.f1 } { type.user.name.last }!
Hello, ${ type.0user.name.first.f1 } ${ type.$user.name.last }!
Hello, ${ type.$user0._name_.first.f1 } ${ type.user$.name.last }!
';
my $regex = qr/\$\{\s*(?<path>[a-zA-Z_$]\w*(?:\.[a-zA-Z_$]\w*)*)\s*\}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}