using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/[0-9]{4}-[0-9]{1,2}-[0-9]{1,2}$";
string substitution = @"/";
string input = @"my-file-path/wefw/wefw/2022-03-20
my-file-path/wefw/2022-01-02
my-file-path/wef/wfe/wefw/wef/2021-02-03
my-file-path/wef/wfe/wef/";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}