#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sU)\d+?[\r\n]+(.*)3.2.P.4.4.\s+Justification\s+of\s+Specifications"
Local $sString = " 26" & @CRLF & _
"Data related to the point SP-WFI-21-Room process fluids " & @CRLF & _
"Sampling Date:16/04/2007 " & @CRLF & _
" 28" & @CRLF & _
"Data related to pint SP-WFI-21-Room process fluids " & @CRLF & _
"Sampling Date: 20/04/2007 " & @CRLF & _
"TEST SPECIFICATIONS RESULTS " & @CRLF & _
"T.O.C. ≤ 500 ppb 6ppb " & @CRLF & _
"Conductivity at 25°C ≤ 1.3 μS.cm-1 1.1 μS.cm-1 " & @CRLF & _
"Data related to the point of use UP-WFI-07 " & @CRLF & _
"Sampling Date: 20/04/2007 " & @CRLF & _
"TEST SPECIFICATIONS RESULTS " & @CRLF & _
"Appearance Clear and colourless liquid Conforms " & @CRLF & _
"pH 5.0 – 7.0 6.20 " & @CRLF & _
"Oxidable substances Conforms Conforms " & @CRLF & _
"Conductivity at 25°C ≤ 1.3 μS.cm-1 1.1 μS.cm-1 " & @CRLF & _
"0 microrg./100ml " & @CRLF & _
"Reference guidelines " & @CRLF & _
"− 3AQ11A: Specifications and Control Tests on the Finished Product - EUDRALEX Volume 3A " & @CRLF & _
"− Topic Q6A, Step 4 Note for Guidance Specifications: Test procedures and Acceptance Criteria for New " & @CRLF & _
"Drug Substances and New Drug Products: Chemical Substances (CPMP/ICH/367/96 - Adopted Nov. 99) " & @CRLF & _
" 29" & @CRLF & _
"3.2.P.4.2 Analytical Procedures " & @CRLF & _
"All the analytical procedures related to the control of excipients are those described in the " & @CRLF & _
"corresponding Ph. Eur. monographs current edition (refer to 3.2.P.4.1). " & @CRLF & _
"Reference guidelines " & @CRLF & _
"− Topic Q2A, Step 5 Note for Guidance on Validation of Analytical Methods: Definitions and Terminology " & @CRLF & _
"(CPMP/ICH/381/95 - adopted Nov. 94) " & @CRLF & _
"− 3AQ14A: Validation of Analytical Procedures: Definition and Terminology - EUDRALEX Volume 3A " & @CRLF & _
"− 3AQ13A: Validation of Analytical Procedures: Methodology - EUDRALEX Volume 3A " & @CRLF & _
"− Topic Q6A, Step 4 Note for Guidance Specifications: Test procedures and Acceptance Criteria for New " & @CRLF & _
"Drug Substances and New Drug Products: Chemical Substances (CPMP/ICH/367/96 - Adopted Nov. 99) " & @CRLF & _
"3.2.P.4.3 Validation of Analytical Procedures " & @CRLF & _
"All the analytical procedures proposed to control the excipients are those reported in Ph. Eur. " & @CRLF & _
"monographs current edition and no variation has been introduced; each method is validated " & @CRLF & _
"concerning specificity and linearity, in order to grant suitability of the instruments used. " & @CRLF & _
"Reference guidelines: " & @CRLF & _
"− Topic Q2A, Step 5 Note for Guidance on Validation of Analytical Methods: Definitions and Terminology " & @CRLF & _
"(CPMP/ICH/381/95 - adopted Nov. 94) " & @CRLF & _
"− 3AQ14A: Validation of Analytical Procedures: Definition and Terminology - EUDRALEX Volume 3A " & @CRLF & _
"− 3AQ13A: Validation of Analytical Procedures: Methodology - EUDRALEX Volume 3A " & @CRLF & _
"3.2.P.4.4. Justification of Specifications "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")