package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\S+=(\([^("]*(?:[^("]*"(?:[^\\"]|\\["\\])*")*(\)))`)
var str = `start=("a", "b") and between=("range(2019, max, to=\"le\")", "b") and end=("a", "b")`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}